Eclipse(更新中) - user000422/0 Wiki

Original URL: https://github.com/user000422/0/wiki/Eclipse(更新中)

知識

HTMLの配置場所 Web-Info下(WebContent直下説もある)

サーバ起動後画面確認 http://localhost/プロジェクト名をURLに指定

設定

軽くする設定 テーマ変更設定 > 一般 > 外観 > テーマ > クラシック アシスト遅延設定 > 一般 > エディタ > コンテンツアウト > 自動有効化遅延「80」

改行時のインデント(タブ)を無効にする方法 ウインドウ -> 設定 -> Java -> コード・スタイル -> フォーマッター -> 編集 -> インデント 「折返しされた行のインデントをインデントにスペースを使用」にチェック

末尾の空白スペースが自動除去される設定を解除 ウィンドウ -> 設定 -> 一般 -> エディター -> AnyEditツール -> 自動変換タブ 末尾の空白を除去のチェックを外す

コメントの最初の方だけ日本語文字化け ウインドウ -> 設定 -> 一般 -> 外観 -> 色とフォント -> Java -> Java エディター・テキスト・フォント -> 編集 -> Consolas以外に変更 -> 適用して閉じる

操作

ショートカット F3 ・・・ メソッドや宣言部分までジャンプ Ctrl + Shift + R ・・・ リソース検索 Alt + Shift + J ・・・ Javadocをつける Alt + Shift + S ・・・ getter, setter 自動生成

プロジェクト作成 ファイル -> 新規 -> その他 -> Web -> 動的Webプロジェクト ※スクール式 ファイル > 新規 > Javaプロジェクト※git先をロケーションにしたい場合はここで設定 ※現場式

メソッドが呼び出されている先メソッド右クリック -> 参照 ※呼び出し階層でいいような?

プロジェクトの名前変更右クリック > リファクタリング > 名前変更

他のプロジェクトをクラスパスに追加 ビルド・パス > ビルドパスの構成 > プロジェクト > 追加 ※? ビルド・パス > クラスフォルダ追加 ※最新メモ

エクスポート … ファイルを出力 対象ファイルを右クリック -> エクスポート -> 一般 -> ファイル・システム

ワークスペース再指定およびインポート 左上のパッケージエリア(フォルダ階層があるエリア) で 右クリック インポート -> 一般 -> 既存プロジェクトをワークスペースへ -> 次へ ルートディレクトリの選択 で新しい指定先フォルダを指定 (オプションで「プロジェクトをワークスペースにコピー」が入ってない状態にする) 完了

文字化けしたpropertiesファイルの見方 対象ファイル右クリック -> 次で開く -> Limyプロパティ・エディター

**ブラウザで確認(リクエスト)** まずはサーバを起動しておく ブラウザに入力するURL http://localhost:8080/動的webプロジェクト名/○○○.html 8080 … Tomcatのポート **ブラウザで確認(Eclipse実行機能)** HTMLファイルを右クリック -> 実行 -> サーバで実行

HTML新規作成 ※WebContentディレクトリ以下に作成すること プロジェクト右クリック -> 新規 -> HTMLファイル

CSS新規作成 ※WebContentディレクトリ以下に作成すること プロジェクト右クリック -> 新規 -> その他 -> web -> CSSファイル

Java新規作成 src右クリック -> 新規 -> クラス -> パッケージにパッケージ名、名前にクラス名を入力

**デプロイ(編集中)** ビューのサーバタブ -> サーバ右クリック -> 追加および除去

pullの仕方 プロジェクト 右クリック -> チーム -> プル 最新の場合 … 「 origin からフェッチする参照がありません -すべて最新です。 」

commitの仕方 必ずpull後に行うこと プロジェクト 右クリック -> チーム -> コミット

ビルド

ビルド … 「build.bat」を実行 -> 「target」フォルダ生成 -> 「target」フォルダ下のファイルをコピー

デバッグ

インスペクション … 変数に格納された値を確認 : 変数を選択し右クリック > インスペクション

その他

チーム開発 ウインドウ -> 設定 -> チーム -> Git -> 構成 -> ユーザー設定 値を自分のものに書き換える

競合が起きた場合 変更点をコピーなどで逃がし プロジェクト 右クリック -> 置換 -> 前の改訂

**jUnit(単体テスト)** プロジェクト右クリック -> ビルド・パス -> ビルド・パスの構成 -> ライブラリー -> ライブラリーの追加 -> JUnit -> 次へ JUnitライブラリー・バージョンJUnit4 -> 完了 -> OK

シナリオテスト WARファイル作成 プロジェクト 右クリック -> エクスポート -> WARファイル 宛先:の右の参照ボタンクリック -> デスクトップ選択 -> 保存 ターゲットランタイム -> 特定のサーバー・ランタイムに最適化のチェックボックスにチェックが入っているか確認 ソースファイル -> エクスポートのチェックボックスにチェックが入っていないことを確認 既存ファイルを上書きのチェックボックスにチェックを入れる -> 完了 SQL作成 ファイル名 ・・・ サイト名_SystemTest.sql