Microchip Studio - msw-winterthur/uC_Board Wiki

«Microchip Studio» ist eine «Integrated Developer Environment» (IDE). Es ist also eine Entwicklungsumgebung, die alles beinhaltet:

Um ein Programm auf einer Hardware zu testen sind folgende Schritte notwendig:

  1. Programmcode schreiben (Editor)
  2. Programm in Maschinensprache übersetzen (kompilieren)
  3. Programm auf den Mikrocontroller herunterladen (Downloader)
  4. Programm auf dem Mikrocontroller ausführen.

Installation

Lade das Programm «Microchip Studio» von dieser Seite herunter:

https://www.microchip.com/en-us/development-tools-tools-and-software/microchip-studio-for-avr-and-sam-devices

Die Installation kann mit den Standardeinstellungen durchgeführt werden.

Empfohlene Einstellungen

Es Empfiehlt sich «Microchip Studio» wie folgt einzurichten (aufklappen).

Advanced Mode

Oben rechts im Fenster kann der Modus gändert werden.

oben Rechts auf den Modus klicken

Color Theme

Tools --> Options -->

Envirinment, General

Zeilennummern

Tools --> Options -->

Texteditor, All Languages, General, Line Numbers

Einrücken mit Leerzeichen

Häufig arbeiten an einem Softwareprojekt verschiedene Entwickler mit verschiedenen Entwicklungsumgebungen. Das bedeutet, dass in ein und dem selben Softwareprojekt verschiedene Editoren zum Einsatz kommen. Dies wiederum führt zu Problemen, weil jeder Editor eine andere Tabulatorbreite und Tabulatoren beim Programmieren häufig verwendet werden. Dieses Problem wird gelöst, indem anstelle von Tabulatoren Leerzeichen eingesetzt werden. Ein Tabulator ist also nicht mehr ein grosses Abstand, sondern eine gewisse Anzahl Leerzeichen. Die meisten Editoren unterstützen diese Funktion von Haus aus:

Tools --> Options -->

Text Editor, All Languages, Tabs

Passende Klammern hervorheben

VAssistX --> Visual Assist Options -->

Highlighting

Ein neues Projekt erstellen

ACHTUNG: Hier wird gezeigt wie ein allgemeines neues Projekt in «Microchip Studio» Erstellt wird. Um eine Vorlage für das uC-Board zu herunter zu laden gehe zu Vorlagen.

  1. Microchip Studio öffnen
  2. File --> New --> Project
  3. Wähle "GCC Executable Project C/C++"
  4. Gib einen aussagekräftigen Namen ein. Achtung: keine Sonderzeichen (auch nicht ä ö ü)!
  5. Wähle einen Speicherort, dieser muss in einem Ordner sein, von dem du ein automatisiertes Backup hast.
  6. Weiter
  7. Wähle in der "Device Selection" den "ATmega2560". Tipp: Nutze das Suchfeld oben rechts.
  8. Weiter
  9. Das Projekt ist jetzt eingerichtet.

Projektverzeichnis (Solution Explorer) Anzeigen

Falls ein Projekt geöffnet ist, aber das Projektverzeichnis (Solution Explorer) nicht angezeigt wird kann dieser über das Menu eingeblendet werden:

View --> Solution Explorer

Projekt öffnen

Um ein Projekt zu öffnen, muss das File mit der Endung ".atsln" geöffnet werden. Andere Datentypen können von "Microchip Studio" zwar angezeigt und bearbeitet werden, spätestens wenn man die Änderungen aber ausprobieren will, muss das gesamte Projekt anstatt ein einzelnes File geöffnet werden.

Falls es sich um ein ZIP-File oder ein anderes Archiv handelt, muss dieses entpackt werden bevor das ".atsln"-File geöffnet wird.

Falls das Projektverzeichnis nicht angezeigt wir, öffne den Solution Exploreer

Programm testen/herunterladen

Verbinden

Das uC-Board muss gespiesen sein --> die Power LED muss leuchten.

Die Atmel ICE Box beziehungsweise den Atmel ICA PCBA mit dem USB-Kabel an den Computer anschliessen. Die Rote LED auf der Box/dem PCB sollte leuchten.

Jetzt den AVR-Anschluss (auf beiden Bildern rechts) mit Hilfe des Flachbandkabels mit dem uC-Board verbinden. Die Grüne LED auf der Box/dem PCB sollte leuchten.

Atmel ICE Box

Atmel ICE PCBA

Programm herunterladen

Übersetzen (kompilieren, engl: compile)

  1. Im Menu auf "Build"
  2. "Build Solution" Falls ein Fehler auftritt muss dieser im Code behoben werden, bevor das Programm heruntergeladen werden kann.

Herunterladen

Wird ein Projekt zum ersten Mal heruntergeladen, muss noch eine ICE-Box gewählt werden:

  1. Im Menu auf "Project"
  2. ganz unten auf "Projektname Properties"
  3. links auf "Tools"
  4. "selected debugger/programmer" auf "Atmel-ICE ..." setzen
  5. "Interface" auf "JTAG" setzen
  6. optional kann die "JTAG Clock" auf maximal ca. 2.5 MHz gesetzt werden. Falls das Herunterladen häufig fehlschlägt sollte die "JTAG Clock" wieder zurück auf 200 kHz gestellt werden.
  7. optional kann "Use external Reset" aktiviert werden. Dies empfiehlt sich vor allem, wenn das Herunterladen häufig fehlschlägt.

Ab jetzt kann das Programm mit folgenden Befehlen heruntergeladen werden.

  1. Im Menu auf "Debug"
  2. "Start Without Debugging"

Falls die das Herunterladen fehlschlägt, am besten nochmals alles ausstecken und wieder einstecken. Falls das nicht hilft, "Microchip Studio" schliessen und erneut öffnen...