sat16 - gpulido-redhat/workshopclaro Wiki

Requisitos: - Satellite - RHEL client

Desde la linea de comandos descargamos los requisitos para registrar el sistema cliente # curl --insecure --output katello-ca-consumer-latest.noarch.rpm https://satellite.opennova.pe/pub/katello-ca-consumer-latest.noarch.rpm # yum localinstall katello-ca-consumer-latest.noarch.rpm

Registramos el sistema usando el Activation Key rhel8 que ya fue creador por el administrador # subscription-manager register --org="OpenNova" --activationkey="rhel8" --force # subscription-manager attach --auto

Debera validar que tenga al menos 3 repostorios: Base, AppStream y Tools de Satellite con el comando # yum repolist

En caso de no tener los repositorios activados, hacerlo manualmente con: # subscription-manager repos --enable=rhel-8-for-x86_64-appstream-rpms # subscription-manager repos --enable=rhel-8-for-x86_64-baseos-rpms # subscription-manager repos --enable=satellite-tools-6.7-for-rhel-8-x86_64-rpms

Instalamos los agentes de katello # yum -y install katello-host-tools # yum -y install katello-host-tools-tracer # yum -y install katello-agent

Validamos la cantidad de erratas descubiertas en el servidor, tome nota de estos datos # yum list-security

Si queremos validar el detalle de esas actualizaciones usamos # yum list-security info

Seleccionamos una actualizacion del tipo bugfix para corregirlas # yum update --advisory=RHBA-2020:3009

Vuelva a validar la cantidad de erratas descubiertas en el servidor y compare con el dato anterior # yum list-security

Este mismo procedimiento puede ser realizado con la interface gráfica, logueese en la plataforma y en Hosts de contenido busque su sistema cliente

En el TAB de Errata busque una actualización que considere critica para el sistema, tome nota del codigo

Seleccione la actualización y aplíquela

Espere que que termine de actualizarse, vuelva a examinar el servidor y busque si la actualizacion aun esta por aplicar

Ejercicio propuesto 02: El desarrollador de la pagina web requiere gestionar el contenido del portal, por ello le pide instalar el siguiente RPM desde el servidor FTP del salón, instalelo con el comando: # yum install git-2.18.2-1.el8_1.x86_64

Por linea de comandos intente hacer un análisis y proponga la actualización de ser necesario

Ejercicio prepuesto 03: El mismo desarrallador ahora requiere contar con librerías del navegador firefox, por ello le pide instalar el paquete desde el recurso FTP con el comando # yum install firefox-68.6.0-1.el8_1.x86_64

Por interface gráfica intente hacer un análisis y proponga la actualización de ser necesario