DNET_GIMPDrawing - NetDevInfraWGinOSSConsortium/NetDevInfraWiki GitHub Wiki

GIMPで絵を描く方法

概要

移行メモ: 元ページの「概要」節は見出しのみで本文が無い(書きかけ)。

詳細

基本的な操作

メニュー

  • 画像編集中の(メニューバーの)メニューには

    • 右クリックからもアクセスできる。
    • ツールボックスからもアクセスできる。
  • 左ペインのツールボックスのカスタマイズは「編集」→「設定」から。

    • アイコンサイズを大きく。
    • アイコンをカラーにする。
    • その他、スタイルの変更などが可能。
    • テーマDarkでメニューの色が突然、黒になったので...
      https://gazocustomize.com/gimp-menufont-change/
  • 右ペインのドッキング・ウィンドウは2段だが、1段や3段にカスタマイズできる。

    • 2段目のタブを1段目のタブにD&Dする。
    • 段追加は、タブを最下部にD&Dする(判定に難アリ)

ショートカット+α

Windowsの標準的な操作で対応可能な部分も多い

  • UNDO:Ctrl+Zなど

  • キャンバス

    • 移動:space+D&D

    • 拡大・縮小:Ctrl+マウスホイール

    • 回転:

      • Shift+マウスホイールでD&D
      • 元に戻したいときは+Ctrlで15度刻みにする。
  • 描画

    • スポイト「O」
    • ブラシ「P」鉛筆「N」
    • 消しゴム:Shift+「E」
    • ブラシ・サイズの大・小:「]」・「[」

編集の開始と終了

画像編集を開始する。

  • 「[ファイル]→[新しい画像]」

    • デジタル画像はピクセルでサイズ指定するかテンプレートから選択。
    • 背景色に透明を指定するかどうか(レイヤー、コラージュしたりする場合)。
  • 画面上に画像ファイルをD&Dする(レイヤー追加になる)

  • 保存はプロジェクト・ファイルとしての保存、画像の保存はエクスポートで。

サイズ変更

  • レイヤー・サイズは「レイヤー」から

    • 「レイヤー・サイズの変更」
    • 「レイヤー・サイズをキャンバスにあわせる」
    • 「レイヤーの拡大・縮小」
  • キャンバス・サイズは「画像」から

    • 「キャンバス・サイズの変更」

    • 「キャンバス・サイズをレイヤーにあわせる」

    • 「キャンバス・サイズを選択範囲にあわせる」

      • 背景に合わせる場合、ファジー選択などで、背景を選択して、選択範囲にあわせる。
      • 被写体にあわせる場合、ファジー選択などで、背景・透明を選択して、選択範囲の反転を行う。
    • 「画像の拡大・縮小」

      • 手動でサイズ指定する
      • サイズ変更後、100%にすると実物大を確認できる。

透明

透明色がない場合、

  • 背景レイヤーがロックされている場合や画像ファイルがサポートしていない場合
  • レイヤー → 透明部分 → アルファチャンネルの追加を行う。

選択

  • ツール → 選択ツール

  • 基本的な選択

    • 矩形選択:矩形を選択

    • 楕円選択:円形を選択

    • 色域を選択:色域で選択

    • ファジー選択

      • 主に背景などの同じ色を自動的に選択

      • 「色域を選択」との違いは連続していることが条件

      • 境界を調整できる。
        ・しきい値を調整するのは難しいらしい。
        ・選択 → 「選択範囲の拡大」を使用してピクセル単位で拡大できる。

  • 高度な選択

    • パスツール:通過点をポイントしてパスから選択範囲を作成(選択と描画で使える)

    • なげなわツール:パスツールをより手書き風にしたもの。

    • 電脳ハサミツール:パスツール、なげなわツールに共通。

    • 前景抽出選択ツール:選択範囲から前景を抽出

    • 切り抜きツール:手動で切り抜く場合

  • メニュー → 選択

    • 選択範囲の反転
    • 選択範囲の解除

絵を描く

新規ウィンドウ

絵が崩れにくくなるので常時表示させておくと良いらしい。

  • 表示 → ナビゲーション・ウィンドウ

  • ソフトの機能が弱いので、OnTopReplicaを使用しても良い。

    • インストールしOnTopReplica を起動
    • 指示に従い、右クリック → Select Window、さらに、右クリック → Select Region

レイヤー

透明シートのようなもので、其々のレイヤーに異なる要素を描くことができる。

  • 「レイヤー」を追加する方法

    • 「新しいレイヤーを追加」でレイヤーを追加
    • または「レイヤーとして開く」で、画像がレイヤー毎に読み込まれる。
    • 画像をコピペすると「レイヤー」で「フローティング選択範囲」になる
      • コレを右クリックして「レイヤの固定」を選択。
      • コレを右クリックして「新しいレイヤーの追加」を選択。
  • 目マークで表示・非表示を切り替えることができる。

  • レイヤーをD&Dで移動させ重なり順を変える。

  • 画像からレイヤーを探す

    • 移動ツールを選択、移動対象をレイヤーにして、
      「つかんだレイヤーまたはガイドを移動」にチェック
    • 画像の一部をクリックしている間、「一部」があるレイヤーがアクティブになる。

オブジェクト的操作

  • 削除、移動、拡大・縮小、回転などオブジェクトに対する基本的操作的な。

  • 「レイヤー」「選択範囲」(フローティング選択範囲)などを対象にできる。
    「選択範囲」はあくまで、選択範囲の変形で、画像の変形ではないので、その後フロート化する。

    • レイヤー
      レイヤーは、メニューの レイヤー → 「内容で切り抜き」を行っておくことで
      オブジェクトっぽくなる。

    • フローティング選択範囲
      選択範囲中の画像に対するオブジェクト的操作はフロート化後に可能になる。

    • フローティング選択範囲にするには、範囲選択後に、

      • Shift+Ctrl+L
      • 選択 → 選択範囲のフロート化
    • フローティング選択範囲を、元に戻すには、

      • Ctrl+H
      • レイヤー → レイヤーの固定
  • その後の操作
    オプションの変形対象:「レイヤー」、「選択範囲」に注意

    • 移動

      • 移動ツールを使用する。
      • ショートカットの「Ctrl+Alt」「Shift+Alt」でD&Dすればフロート化しなくてもOK。
      • 整列:整列ツールを使用する。
    • 変形

      • 拡大縮小:拡大・縮小ツールを使用する。
      • 自由変形:統合変形ツールを使用する。
      • 角度調節:回転ツールを使用する。15度刻みは+ShiftでD&D。
      • 鏡像反転:上下、左右を選択可能
      • パース:遠近法ツールを修正する変換
      • 遠近法:遠近法を修正する変換
      • ワープ変形:デブを痩せさせる手捻り
      • ゲージ変形:ワープの亜種でアンカーを使う
    • 削除

      • 選択範囲をDeleteで削除すると削除した範囲は透明色か、
        透明色がない場合は背景色になる。
      • 選択範囲の拡大を行った場合、削除前に選択 → 「境界をぼかす」を使用すると良い。

線描

  • ブラシ
    • ブラシツール:輪郭が少しボケた線を引く。

    • 鉛筆ツール:縁をぼかさずアンチエイリアスがかからない。

    • エアブラシツール:「割合」と「流量」に応じて吹き付ける。

    • インクツール:ドラッグするスピードによって、線の太さを変えられる。

    • パスツール:通過点をポイントしてパスに沿って描画する。

    • ショートカット

      • ブラシ・サイズの大・小:「]」・「[」
    • その他

      • ブラシの設定ができる。
      • 不透明度が調整できる。
      • エアブラシでは流量を調節できる。

塗る

  • ブラシで塗る。

  • 塗りつぶしツールで塗りつぶす。

    • 近似色の領域を描画色で塗りつぶす。
    • 選択範囲を塗りつぶす。
  • レイヤーで透明度ロック

    • 描画した部分に対して操作(塗る)できるようにする。
    • レイヤーダイアログのチェックボックスで「透明保護」を設定する。
  • 透明化

    • レイヤー → 透明部分 → 「Color to Alpha(色を透明度に)」で指定の色を透明化できる。
    • 「ファジー選択」「色域を選択」選択ツールで選択して削除することで
      部分を透明にすることもできる。
  • 非破壊編集

    • クリッピングマスク
      下のレイヤで描画した部分にだけペイントする。

      • 「レイヤーグループ」の中に「レイヤー」を2つ用意
      • 2つのレイヤーのうち、上のレイヤーを選択し、
        右クリック→「合成モード」→「Clip to Backdrop」
    • レイヤーマスク
      XORでマスクするので黒で塗ると消せる(白で塗ると戻せる)。

      • 選択したレイヤーを右クリック
      • [レイヤーマスクの追加]を選択

編集

  • ツールボックス

    • 変形ツール

      • 統合変形
      • 拡大縮小、回転、剪断変形、鏡像反転、遠近法、3D変形
      • ハンドル変形:パースの歪みを補正する、例えば、斜めったビルを真っ直ぐにできる。
      • ワープ変形:デブを痩せさせるアレ。
      • ケージ変形:頭身などのバランスを変形。
    • エフェクト系ツール

      • グラディエーション
      • にじみ、ぼかし/シャープ、暗室、
      • テキスト
  • 色系はメニューの色から

    • 色相 - 彩度:

      • 色相:隣り合った色(RMBCGY)が混じる。
      • 輝度:明るさを明るくする。
      • 彩度:色を鮮やかにする(特定の色を指定可能)。
    • 露出:黒レベルと露出(明るさ)

    • レベル:露出に似た調整ができる。

    • トーンカーブ:露出に似た調整が黒白以外の色にもできる。

    • 明るさ・コントラスト:露出と違って全体的に効いてしまう。

    • 自動調整 → ホワイトバランス:明るさ・コントラストを自動で。

  • フィルター系はメニューのフィルターから

    • ぼかし系

      • 焦点:焦点を選択し周辺に適用する。
      • ガウス:クイックマスク → ブラシで選択して適用する。
      • モザイク処理:クイックマスク → ブラシで選択して適用する。
      • 線形モーション:クイックマスク → ブラシで選択して適用する
        (動きでぼやけたような感じになる)。
      • メディアン:色彩をぼかすとアニメ風になる。
      • 円形モーション:楕円選択を反転し周辺に適用する。
      • 放射状モーション:楕円選択を反転し周辺に適用する。
    • 強調系
      https://docs.gimp.org/2.10/en/filters-enhance.html

      • アンチエイリアス:ギザギザを滑らかにする。
      • ディテール:細部を補正してシャープにする。
      • インターレース除去:TV画面の横縞を除去する。
      • ノイズ除去:ゴミやノイズをぼかして目立たなくする。
      • 赤目除去:赤目を消すことができる。
      • Symmetric Nearest Neighbor:絵画調になる。
    • 照明と投影
      https://docs.gimp.org/2.10/en/filters-light-and-shadow.html

      • Bloom:もわっとする。
      • Supernova:超新星を思わせる大きな星を作成
      • Lens Flare:太陽の輪っか
      • Gradient Flare:光源の輪っかや放射線
      • Lighting Effects:照明があたったような
      • Sparkle:最も明るいポイントに輝きを追加
      • Vignette:画像の周辺部に向かって明るさが減少
    • 芸術的効果
      https://docs.gimp.org/2.10/en/filters-artistic.html

      • キャンバス
      • 水彩
      • 油化
      • 漫画
      • キュビズム
      • ゴッホ
      • ガラスタイル
    • アニメーション
      https://docs.gimp.org/2.10/en/filters-animation.html

  • フェイク技法

    • 不要なものを消すには、周辺画像で塗るツールを使用する。
    • 存在しないものを足すには、足した周辺画像の境界を周辺画像で塗るツールを使用する。
    • ツール
      • 修復ブラシ
      • スタンプで描画

参考


Tags: 移行, 子供向け, 画像編集, GIMP, 開発基盤

⚠️ **GitHub.com Fallback** ⚠️