Troubleshooting - EFeru/hoverboard-firmware-hack-FOC Wiki

The board is not turning on, you hear the power stage buzz noise but no melody

  • Can happen if you haven't flashed the chip properly, make sure you hold the button while flashing so the chip is always powered
  • The chip might be defective, can you connect to it with st-link utility while keeping the button pressed? Even if you feed the board with 3.3v from the st-link ?
  • The 5v or 3.3v dc-dc converters could be defective, you can usually find the same dc-dc converters on the sideboards
  • If the board draws more than 100mA in idle, it's probably broken

The board is not turning on, you can't hear the power stage buzz noise, and no melody

  • the top TIP127 mosfet might be defective (Q2 in schematics)

The board is turning on as soon as the battery or charger is connected

  • The top TIP127 mosfet is probably shorted (Q2 in schematics). Use a multi-meter to check the continuity between drain and source. If your multi-meter beeps, the mosfet is shorted so you need to replace it

When plugging in the battery, the XT60 connector burns

  • It could be at least 2 mosfets of the same half-bridge/phase are shorted. Use a multi-meter to check the continuity between drain and source. If your multi-meter beeps, the mosfet is shorted so you need to replace it

You are unable to unlock the chip or flash the firmware

  • Check this section

The board turns on/off/on/off.....

The board is turning off

You hear beeps

  • Check Diagnostics section
  • Please also check in the Wiki the troubleshooting section of the variant you are using

The board turns on, there are no error beeps, wheels are not spinning

Wheels are not spinning in a smooth/normal way