AtmosphereServlet30 for Servlet 3.0 Container ONLY - Atmosphere/atmosphere Wiki

This apply only to Atmosphere 1.0.x. For 2.0.x, see this

If your planning to deploy Atmosphere in Servlet 3.0 only Container, you can use the AtmosphereServlet30 instead of AtmosphereServlet:

    <servlet>
        <description>AtmosphereServlet</description>
        <servlet-name>AtmosphereServlet</servlet-name>
        <servlet-class>org.atmosphere.cpr.AtmosphereServlet30</servlet-class>
        <async-supported>true</async-supported>

Atmosphere will use the Servlet 3.0 Async API and will not attempts to use any native implementation like CometSupport, Grizzly Comet etc.