I ‐ Getting Started - V-Loic/Test GitHub Wiki

⚒️ Installation

Linux UNIX and Mac OS versions

iPhyloGeo++ is available as a Python script.

Prerequisites

💡 Before using this program, make sure that you have installed all the necessary libraries for it to work properly. To do this, simply type the following command:

pip3 install -r requirements.txt

Python script

A requirements.txt file containing all required libraries is available in the GitHub repository.

⚠️ Assuming Python 3.8 or higher is installed on the machine, the script should run well with the libraries installed.

Here is an example of how to run the script in Linux/UNIX or Mac OS:

  1. After downloading the source code, go to the folder containing main.py.
  2. If you do not have virtualenv installed, run python3 -m pip install --user virtualenv
  3. Create a new virtual environment (venv) in your terminal using python3 -m venv iPhyloGeo++_env.
  4. Still in the terminal, enter the new venv using source iPhyloGeo++_env/bin/activate.
  5. Install the required libraries using pip install -r requirements.txt.
  6. Launch aPhyloGeo using python3 main.py.